Skip to main content
CVE-2026-119923VulnerabilityPublished

Heap-based Buffer Overflow

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119923· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 6.0.2 : patch Amazon Aurora PostgreSQL with Babelfish as a priority.

Data as of 6 Nov 2026, 22:47 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (AMZN)CVSS 3.19.8
CNA (AMZN)CVSS 4.09.3
Patch
Available – fixed in 6.0.2, 5.4.2, 5.3.2 +21
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
AWSbabelfish-for-postgresqlAffected
  • >=1.0 <=1.5
  • >=2.1 <=2.15
  • >=3.1 <=3.12
  • >=4.0 <=4.8
  • >=5.1 <=5.4
Fixed in–
AmazonAmazon Aurora PostgreSQL with BabelfishAffected
  • >=1.0.0 <1.5.5
  • >=1.6.0 <1.17.2
  • >=2.0.0 <2.3.5
  • >=2.4.0 <2.12.4
  • >=2.13.0 <2.13.3
  • >=2.14.0 <2.14.2
  • >=2.15.0 <2.15.2
  • >=2.16.0 <2.16.1
  • >=3.0.0 <3.8.4
  • >=3.9.0 <3.9.4
  • >=3.10.0 <3.10.3
  • >=3.11.0 <3.11.2
  • >=3.12.0 <3.12.2
  • >=3.13.0 <3.13.1
  • >=4.0.0 <4.5.5
  • >=4.6.0 <4.6.3
  • >=4.7.0 <4.7.2
  • >=4.8.0 <4.8.2
  • >=4.9.0 <4.9.1
  • >=5.0.0 <5.1.4
  • >=5.2.0 <5.2.3
  • >=5.3.0 <5.3.2
  • >=5.4.0 <5.4.2
  • >=6.0.0 <6.0.2
  • =5.5.0
Fixed in
  • 6.0.2
  • 5.4.2
  • 5.3.2
  • 5.2.3
  • 5.1.4
  • 4.9.1
  • 4.8.2
  • 4.7.2
  • 4.6.3
  • 4.5.5
  • 3.13.1
  • 3.12.2
  • 3.11.2
  • 3.10.3
  • 3.9.4
  • 3.8.4
  • 2.16.1
  • 2.15.2
  • 2.14.2
  • 2.13.3
  • 2.12.4
  • 2.3.5
  • 1.17.2
  • 1.5.5
GitHubbabelfish-for-postgresql/babelfish-for-postgresqlpkg:github/babelfish-for-postgresql/babelfish-for-postgresqlOther threatsAffected
  • =5.5.0
  • >=1.0.0 <1.5.5
  • >=1.6.0 <1.17.2
  • >=2.0.0 <2.3.5
  • >=2.4.0 <2.12.4
  • >=2.13.0 <2.13.3
  • >=2.14.0 <2.14.2
  • >=2.15.0 <2.15.2
  • >=2.16.0 <2.16.1
  • >=3.0.0 <3.8.4
  • >=3.9.0 <3.9.4
  • >=3.10.0 <3.10.3
  • >=3.11.0 <3.11.2
  • >=3.12.0 <3.12.2
  • >=3.13.0 <3.13.1
  • >=4.0.0 <4.5.5
  • >=4.6.0 <4.6.3
  • >=4.7.0 <4.7.2
  • >=4.8.0 <4.8.2
  • >=4.9.0 <4.9.1
  • >=5.0.0 <5.1.4
  • >=5.2.0 <5.2.3
  • >=5.3.0 <5.3.2
  • >=5.4.0 <5.4.2
  • >=6.0.0 <6.0.2
Fixed in
  • 1.5.5
  • 1.17.2
  • 2.3.5
  • 2.12.4
  • 2.13.3
  • 2.14.2
  • 2.15.2
  • 2.16.1
  • 3.8.4
  • 3.9.4
  • 3.10.3
  • 3.11.2
  • 3.12.2
  • 3.13.1
  • 4.5.5
  • 4.6.3
  • 4.7.2
  • 4.8.2
  • 4.9.1
  • 5.1.4
  • 5.2.3
  • 5.3.2
  • 5.4.2
  • 6.0.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Babelfish for PostgreSQL extension to versions 4.10, 5.6, 6.1 or later. Customers using Amazon Aurora PostgreSQL with Babelfish must upgrade their clusters to the specified patched versions (e.g., Aurora PostgreSQL 13.9.16 (1.5.5), 14.14.1 (4.10.0), 17.10.1 (5.6.0), 18.4.1 (6.1.0), etc.) and apply any pending maintenance updates. As a temporary workaround, restrict network access to the TDS port (default 1433) to prevent remote exploitation until upgrades can be applied.

Description

A heap-based buffer overflow vulnerability exists in the TDS prelogin parser of the Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4, and in Amazon Aurora PostgreSQL with Babelfish. This flaw allows remote attackers to execute arbitrary OS commands as the database process user by sending a specially crafted malformed TDS prelogin packet to the TDS port. A related NULL-pointer dereference issue in the same parser is also consolidated in this record. Users are advised to upgrade to fixed versions or apply recommended workarounds.

References

Community reviews

Loading reviews…