CVE-2026-6679: wolfssl · Heap Buffer Overflow Could Occur
Affects wolfsslSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 5.9.1 : patch wolfssl soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubwolfssl/wolfsslpkg:github/wolfssl/wolfsslOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in wolfSSL version 5.9.1. Users should upgrade to version 5.9.1 or later to remediate this vulnerability.
Description
A heap buffer overflow vulnerability exists in the DTLS 1.3 ACK serialization path of wolfSSL versions 5.9.0 and earlier. The flaw is caused by an integer truncation error that leads to allocation of an undersized buffer, which is then overrun. This vulnerability was fixed in wolfSSL version 5.9.1.