Red Hat Security Advisory: Red Hat Quay 3.15.7
Affects Red HatSource GCVE Database
Public exploit available · CVSS 7.7 High.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P/S:N/AU:Y/R:U/V:D/RE:M/U:AmberExploitation evidence
Disclosed: evidence found.
CVE published 30 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| juliangruberbrace-expansion | Affected
| Fixed in– |
npmbrace-expansionpkg:npm/brace-expansionOther threats | Affected
| Fixed in– |
npmbrace-expansionpkg:npm/brace-expansionOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Red Hat Quay 3.15.7 includes fixes for this vulnerability. Users should ensure all previously released errata are applied and upgrade to Red Hat Quay 3.15.7 or later. There is no practical mitigation other than upgrading to a fixed version of the brace-expansion package when it becomes available. The vulnerability is typically introduced via transitive dependencies (minimatch, glob), making isolation difficult.
Description
A denial of service (DoS) vulnerability exists in the brace-expansion npm package used by Red Hat Quay. The expand() function can be triggered with specially crafted input containing consecutive non-expanding brace groups, causing exponential-time complexity and high CPU consumption that blocks the event loop. This can lead to service disruption. No practical mitigation exists other than upgrading to a fixed version when available.
References
- access.redhat.com/errata/RHSA-2026:48933 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-13149 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-45822 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-54058 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-54060 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-55379 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-55380 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59197 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59199 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59200 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59204 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59205 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59885 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59886 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2026/rhsa-2026_48933.json (opens in a new tab)