Skip to main content
CVE-2026-121925VulnerabilityPublished

libsnowflakeclient · Stack-based Buffer Overflow

Affects libsnowflakeclientSource GCVE Database

0
Compare
Authoritative record:CVE-2026-121925· Medium 6.6

Not known to be exploited · CVSS 6.6 Medium · fixed in 2.11.1 : update libsnowflakeclient when convenient.

Data as of 4 Nov 2026, 15:17 UTC

CVSS 3.1 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (SNOWFLAKE)CVSS 3.16.6
Patch
Available – fixed in 2.11.1, 4.3.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade snowflakedb/libsnowflakeclient to 2.11.1; snowflake/php-pdo to 4.3.0.

Affected software

ProductAffectedFixed in
GitHubsnowflakedb/libsnowflakeclientpkg:github/snowflakedb/libsnowflakeclientOther threatsAffected
  • <2.11.1
Fixed in
  • 2.11.1
Packagistsnowflake/php-pdopkg:composer/snowflake/php-pdoOther threatsAffected
  • <4.3.0
Fixed in
  • 4.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should manually upgrade to libsnowflakeclient version 2.11.1 and Snowflake PHP PDO Driver version 4.3.0 where the vulnerability is fixed. No other mitigations are specified.

Description

A stack-based buffer overflow vulnerability exists in libsnowflakeclient and the Snowflake PHP PDO Driver during SAML-based authentication. The flaw occurs when a value from the identity provider's HTML response is copied into a fixed-size buffer without length validation. An attacker controlling or redirecting the SAML endpoint could exploit this by sending an oversized response, potentially causing a crash or remote code execution. Fixed versions are libsnowflakeclient 2.11.1 and Snowflake PHP PDO Driver 4.3.0.

References

Community reviews

Loading reviews…