Skip to main content
VulnerabilityPublished

CVE-2026-121925: Snowflake PHP PDO Driver · Stack-based Buffer Overflow

Affects Snowflake PHP PDO DriverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.6 Medium : upgrade to 4.3.0 when convenient.

Data as of 4 Nov 2026, 11:58 UTC

CVSS 3.1 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (SNOWFLAKE)CVSS 3.16.6
Patch
Available – fixed in 4.3.0, 2.11.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade Snowflake to 4.3.0 (PHP PDO Driver) or 2.11.1 (Libsnowflakeclient).

Affected software

ProductAffectedFixed in
SnowflakeSnowflake PHP PDO DriverAffected
  • >=3.2.0 <4.3.0
Fixed in
  • 4.3.0
SnowflakeSnowflake LibsnowflakeclientAffected
  • >=2.1.0 <2.11.1
Fixed in
  • 2.11.1
GitHubSnowflake PHP PDO Driverpkg:github/Snowflake PHP PDO DriverOther threatsAffected
  • >=3.2.0 <4.3.0
Fixed in
  • 4.3.0
GitHubSnowflake Libsnowflakeclientpkg:github/Snowflake LibsnowflakeclientOther threatsAffected
  • >=2.1.0 <2.11.1
Fixed in
  • 2.11.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and users must manually upgrade to libsnowflakeclient version 2.11.1 and Snowflake PHP PDO Driver version 4.3.0 to remediate this vulnerability. No other mitigation or workaround is indicated.

Description

CVE-2026-121925 is a stack-based buffer overflow vulnerability in the Snowflake PHP PDO Driver and libsnowflakeclient that occurs during SAML-based authentication. The flaw arises from copying a value from the identity provider's HTML response into a fixed-size buffer without length validation. An attacker controlling or redirecting the SAML endpoint could exploit this by sending an oversized response, potentially causing a crash or remote code execution. Fixed versions are libsnowflakeclient 2.11.1 and Snowflake PHP PDO Driver 4.3.0.

References

Community reviews

Loading reviews…