Skip to main content
CVE-2026-59385VulnerabilityPublished

A user with SpaceDeveloper privileges could modify the URL of a space-scoped broker without altering its credentials

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-59385· Low 2.7

Not known to be exploited · CVSS 2.7 Low : upgrade to 1.248.0 when convenient.

Data as of 30 Oct 2026, 10:31 UTC

CVSS 3.1 base score
2.7Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (vmware)CVSS 3.12.7
Patch
Available – fixed in 1.248.0, 60.9.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade CAPI (Cloud Foundry Controller) to 1.248.0; CF Deployment to 60.9.0.

Affected software

ProductAffectedFixed in
Cloud FoundryCAPI (Cloud Foundry Controller)Affected
  • <1.248.0
Fixed in
  • 1.248.0
Cloud FoundryCF DeploymentAffected
  • <60.9.0
Fixed in
  • 60.9.0

AI-suggested

Since the vulnerability requires SpaceDeveloper privileges, restricting these privileges to trusted users can mitigate risk. Monitor vendor advisories for any official fixes or updates.

Description

CVE-2026-59385 describes a vulnerability where a user with SpaceDeveloper privileges can modify the URL of a space-scoped broker without changing its credentials. This allows the user to indirectly extract existing broker credentials by redirecting them to a broker they control. The Cloud Foundry API does not allow direct reading of broker credentials, so this method bypasses that restriction. The vulnerability has a low severity score of 2.7 and does not impact integrity or availability.

References

Community reviews

Loading reviews…