Skip to main content
VulnerabilityPublished

CVE-2026-59385: CAPI (Cloud Foundry Controller) · Space Developer can extract space-scoped broker credentials

Affects CAPI (Cloud Foundry Controller)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.7 Low : upgrade to 1.248.0 when convenient.

Data as of 30 Oct 2026, 12:04 UTC

CVSS 3.1 base score
2.7Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (vmware)CVSS 3.12.7
Patch
Available – fixed in 1.248.0, 60.9.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade CAPI (Cloud Foundry Controller) to 1.248.0; CF Deployment to 60.9.0.

Affected software

ProductAffectedFixed in
Cloud FoundryCAPI (Cloud Foundry Controller)Affected
  • <1.248.0
Fixed in
  • 1.248.0
Cloud FoundryCF DeploymentAffected
  • <60.9.0
Fixed in
  • 60.9.0

AI-suggested

Upgrade to Cloud Foundry CAPI versions 1.248.0 or later, or 60.9.0 or later, where this vulnerability has been fixed. No other mitigation is indicated or necessary as the fix addresses the root cause.

Description

CVE-2026-59385 is a vulnerability in Cloud Foundry's CAPI (Cloud Foundry Controller) that allows a user with SpaceDeveloper privileges to indirectly extract space-scoped broker credentials. This is achieved by modifying the URL of a space-scoped broker to redirect credentials to a broker under their control, bypassing the CF API's restriction on direct credential reading. The vulnerability affects versions prior to 1.248.0 and 60.9.0, where fixes have been applied.

References

Community reviews

Loading reviews…