CVE-2026-59386: Cloud Foundry Controller (CAPI) · Credential Exposure to Space Supporter
Affects Cloud Foundry Controller (CAPI)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 60.9.0 when convenient.
Data as of 30 Oct 2026, 12:04 UTC
Thin evidence
One scorer or none| CNA (vmware) | CVSS 3.1 | 6.5 |
|---|
- Patch
- Available – fixed in 60.9.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade cf-deployment to 60.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Cloud FoundryCloud Foundry Controller (CAPI) | Affected
| Fixed in– |
| Cloud Foundrycf-deployment | Affected
| Fixed in
|
AI-suggested
Upgrade affected Cloud Foundry Controller (CAPI) instances to version 60.9.0 or later, where this vulnerability has been fixed. No additional mitigations are indicated by the vendor advisory.
Description
CVE-2026-59386 is a vulnerability in Cloud Foundry Controller (CAPI) that allows a SpaceSupporter to escalate privileges improperly. By modifying an application's start command and buildpack—actions normally restricted to SpaceDeveloper roles—an attacker can retrieve service credentials without authorization. This flaw affects versions up to 60.9.0, where it has been fixed.