CVE-2026-59396: Cloud Foundry UAA · DoS Vulnerability
Affects Cloud Foundry UAASource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 79.9.0 when convenient.
Data as of 30 Oct 2026, 09:00 UTC
Thin evidence
One scorer or none| CNA (vmware) | CVSS 4.0 | 6.9 |
|---|---|---|
| CNA (vmware) | CVSS 3.1 | 4.9 |
- Patch
- Available – fixed in 79.9.0, 60.11.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade UAA to 79.9.0; cf-deployment to 60.11.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Cloud FoundryUAA | Affected
| Fixed in
|
| Cloud Foundrycf-deployment | Affected
| Fixed in
|
AI-suggested
Fixed versions 79.9.0 and 60.11.0 are available and should be applied to remediate this vulnerability. No additional mitigation steps are indicated. Users should upgrade affected UAA instances to these versions to prevent denial-of-service conditions caused by this flaw.
Description
CVE-2026-59396 is a denial-of-service vulnerability in Cloud Foundry UAA's private_key_jwt client-authentication mechanism. It arises from the handling of remote JWKS URI responses, which are cached and fully deserialized upon invalid authentication attempts. An attacker with write access to clients or a compromised endpoint can send anonymous requests that repeatedly trigger parsing of large cached objects, causing excessive CPU usage and potential Java heap exhaustion, leading to service unavailability. The vulnerability affects UAA versions >=76.23.0 <79.9.0 and >=0 <60.11.0. Fixed versions are 79.9.0 and 60.11.0. The CVSS 4.0 score is 6.9 (medium severity).