Skip to main content
VulnerabilityPublished

CVE-2026-59387: CAPI (Cloud Controller API) · Broken Access Control Restriction

Affects CAPI (Cloud Controller API)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 1.247.0 soon.

Data as of 30 Oct 2026, 09:14 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (vmware)CVSS 3.18.8
Patch
Available – fixed in 1.247.0, 60.7.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade CAPI (Cloud Controller API) to 1.247.0; cf-deployment to 60.7.0.

Affected software

ProductAffectedFixed in
Cloud FoundryCAPI (Cloud Controller API)Affected
  • <1.247.0
Fixed in
  • 1.247.0
Cloud Foundrycf-deploymentAffected
  • <60.7.0
Fixed in
  • 60.7.0

AI-suggested

A fix is available in Cloud Foundry Cloud Controller API versions 1.247.0 and 60.7.0. Users should upgrade to these versions or later to remediate the vulnerability. No alternative mitigations are indicated. Applying the official patch is the recommended remediation.

Description

CVE-2026-59387 is a broken access control vulnerability in the Cloud Foundry Cloud Controller API (CAPI). The Nginx routing configuration blocks unauthenticated access to certain internal API endpoints but omits this protection for /internal/v3/. This allows unauthenticated access to staging callback endpoints, enabling attackers with a valid build or droplet GUID to forge staging callbacks, transition droplets to STAGED state, and persist arbitrary metadata without proper authorization. The vulnerability enables privilege escalation beyond intended role boundaries because a SpaceAuditor can enumerate GUIDs without write permissions.

References

Community reviews

Loading reviews…