CVE-2025-46647: Apache APISIX · Vulnerability of Plugin Openid-connect
Source GCVE Database
Not known to be exploited · CVSS 5.3 Medium · fixed in 3.12.0 : update Apache APISIX when convenient.
Data as of 4 Nov 2026, 17:52 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 5.3 |
|---|
- Affects
- Apache APISIX prior to 3.12.0
- Patch
- Available – fixed in 3.12.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
AI-suggested
Users should upgrade Apache APISIX to version 3.12.0 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.
Description
A vulnerability exists in the openid-connect plugin of Apache APISIX versions prior to 3.12.0. This flaw affects configurations using introspection mode where multiple issuers share the same private key and rely solely on issuer differentiation. An attacker with a valid account on one issuer could potentially authenticate as a user on another issuer. The vulnerability has a medium severity with a CVSS score of 5.3.