Skip to main content
VulnerabilityPublished

CVE-2026-19244: HKUDS nanobot · CWE-266

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-19244· Medium 5.1

Public exploit available · CVSS 5.1 Medium.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
HKUDSnanobotAffected
  • =0.2.0
  • =0.2.1
Fixed in–
GitHubhkuds/nanobotpkg:github/hkuds/nanobotOther threatsAffected
  • =0.2.0
  • =0.2.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade HKUDS nanobot to version 0.3.0 or later, which includes the official fix (patch 4436) correcting the registration boundary for MCP resources and prompt wrappers. No additional mitigation steps are indicated as the issue is resolved by this upgrade.

Description

A vulnerability in HKUDS nanobot up to version 0.2.1 affects the connect_mcp_servers function in the MCP enabledTools Scope Handler component. This flaw allows improper access control due to MCP resource and prompt wrappers being registered outside their intended scope. The vulnerability can be exploited remotely. Public exploit code exists. Upgrading to version 0.3.0 resolves the issue.

References

Community reviews

Loading reviews…