Skip to main content
VulnerabilityPublished

CVE-2026-19244: HKUDS nanobot · Improper Access Controls

Affects HKUDS nanobotSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.1 Medium.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
HKUDSnanobotAffected
  • =0.2.0
  • =0.2.1
Fixed in–
GitHubhkuds/nanobotpkg:github/hkuds/nanobotOther threatsAffected
  • =0.2.0
  • =0.2.1
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:nanobot:nanobot:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade HKUDS nanobot to version 0.3.0 or later, which includes the fix for this vulnerability by correcting the MCP resource and prompt wrapper registration boundaries. Applying this upgrade fully mitigates the issue.

Description

A vulnerability was detected in HKUDS nanobot up to 0.2.1. The affected element is the function connect_mcp_servers of the file nanobot/agent/tools/mcp.py of the component MCP enabledTools Scope Handler. Performing a manipulation results in improper access controls. The attack is possible to be carried out remotely. The exploit is now public and may be used. Upgrading to version 0.3.0 is sufficient to fix this issue. The patch is named 4436. You should upgrade the affected component. Multiple issues were reported to the project. They reacted with a high level of professionalism and kindness: "Both reports describe the same root cause: MCP resource and prompt wrappers could be registered outside the intended enabledTools scope. The registration boundary was corrected".

References

Community reviews

Loading reviews…