Skip to main content
VulnerabilityPublished Updated

CVE-2026-108817: agno-agi agno · Command Injection

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-108817· Medium 5.1

Public exploit available · CVSS 5.1 Medium · fixed in 3.0.10 : patch agno as a priority.

Data as of 3 Nov 2026, 10:57 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.1
CNA (VulDB)CVSS 3.15.5
CNA (VulDB)CVSS 3.05.5
CNA (VulDB)CVSS 2.06.5
EPSS
1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.10
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
agno-agiagnoAffected
  • 3.0.0 – 3.0.9
10 affected builds
Fixed in–
PyPIagno-agi/agnopkg:pypi/agno-agi/agnoOther threatsAffected
  • 3.0.0 – 3.0.9
10 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the agno-agi agno component to version 3.0.10, where this vulnerability is fixed. No other mitigations are specified or required.

Description

A command injection vulnerability exists in agno-agi agno up to version 3.0.9 in the function agno.CodingTools.run_shell. This flaw allows remote attackers with limited privileges to manipulate shell commands, potentially leading to partial confidentiality, integrity, and availability impacts. The issue is resolved by upgrading to version 3.0.10.

References

Community reviews

Loading reviews…