Skip to main content
CVE-2026-105979VulnerabilityPublished

Improper Input Validation

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-105979· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 3.5.116 soon.

Data as of 3 Nov 2026, 10:43 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (CERTVDE)CVSS 4.08.6
CNA (CERTVDE)CVSS 3.17.2
Patch
Available – fixed in 3.5.116, 1.0.124, 1.0.123
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade TK100 to 3.5.116; TK500-v2 to 1.0.124; TK500-v3 to 1.0.123.

Affected software

ProductAffectedFixed in
WelotecTK100Affected
  • <3.5.116
Fixed in
  • 3.5.116
WelotecTK500-v2Affected
  • <1.0.124
Fixed in
  • 1.0.124
WelotecTK500-v3Affected
  • <1.0.123
Fixed in
  • 1.0.123

AI-suggested

If you cannot patch yet, restricting access to the ZeroTier VPN function to trusted users and limiting high privilege accounts may reduce risk.

Description

A vulnerability in the ZeroTier VPN function allows a remote attacker with high privileges to inject and execute system commands as root due to improper input validation.

References

Community reviews

Loading reviews…