Skip to main content
VulnerabilityPublished Updated

CVE-2026-71513: Acronym · NLTK AllowlistUnpickler dotted-name validation bypass allows remote code execution

Affects acronymSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 2.0.0_5 soon.

Data as of 30 Oct 2026, 07:30 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.0.0_5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade acronym to 2.0.0_5.

Affected software

ProductAffectedFixed in
Homebrewacronympkg:brew/acronymOther threatsAffected
  • >=2.0.0_4 <2.0.0_5
Fixed in
  • 2.0.0_5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

NLTK before 3.10.3 contains a remote code execution vulnerability in AllowlistUnpickler that validates only the pickle module string and not the global name, allowing attackers to resolve dotted names by attribute traversal to callables outside the allowlisted namespace. Attackers can craft untrusted transition-parser models that execute arbitrary commands when TransitionParser.parse loads the model through allowlisted_pickle_load.

References

Community reviews

Loading reviews…