Skip to main content
VulnerabilityPublished Updated

CVE-2025-71408: Acronym · NLTK vulnerable to Eval Injection via collocations CLI arguments

Affects acronymSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 2.0.0_2 soon.

Data as of 30 Oct 2026, 07:30 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.0.0_2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade acronym to 2.0.0_2.

Affected software

ProductAffectedFixed in
Homebrewacronympkg:brew/acronymOther threatsAffected
  • >=2.0.0 <2.0.0_2
Fixed in
  • 2.0.0_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

NLTK (Natural Language Toolkit) before version 3.9.3 contains an eval injection vulnerability in the nltk.collocations module that allows an attacker who controls command-line arguments to execute arbitrary Python code. When collocations.py is invoked directly, the __main__ block passes command-line arguments directly to eval() as suffixes of BigramAssocMeasures without allowlist validation or sanitization, enabling an attacker to supply a Python expression that escapes the intended attribute lookup and executes arbitrary code including OS commands via the os module.

References

Community reviews

Loading reviews…