Skip to main content
VulnerabilityPublished Updated

CVE-2025-54119: Adodb php · The ADOdb sqlite3 driver allows SQL injection

Affects adodb/adodb-phpSource GCVE Database

0
Compare
Authoritative record:CVE-2025-54119· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 5.22.10 as a priority.

Data as of 29 Oct 2026, 23:54 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.110.0
Patch
Available – fixed in 5.22.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade adodb/adodb-php to 5.22.10.

Affected software

ProductAffectedFixed in
Packagistadodb/adodb-phpAffected
  • <5.22.10
Fixed in
  • 5.22.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to ADOdb version 5.22.10 or later, where this vulnerability is fixed. As a workaround, ensure that only controlled, trusted data is passed to the metaColumns(), metaForeignKeys(), and metaIndexes() methods' $table parameter to prevent injection.

Description

ADOdb PHP's SQLite3 driver contains a critical SQL injection vulnerability due to improper escaping of query parameters in the metaColumns(), metaForeignKeys(), and metaIndexes() methods when called with crafted table names. This flaw allows an attacker to execute arbitrary SQL statements if untrusted input is passed to these methods. The vulnerability is fixed in version 5.22.10.

References

Community reviews

Loading reviews…