Skip to main content
VulnerabilityPublished Updated

pferd · aiohttp: Multiple instances of excessive or unbounded memory/CPU use

Affects pferdSource GCVE Database

0

CVSS 8.7 High : upgrade to 3.10.0 soon.

Data as of 27 Oct 2026, 23:13 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.10.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

What to do

Upgrade pferd to 3.10.0.

Affected software

ProductAffectedFixed in
Homebrewpferdpkg:brew/pferdOther threatsAffected
  • >=3.4.2 <3.10.0
Fixed in
  • 3.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade aiohttp to version 3.10.0 or later, where these issues have been fixed. Since a patch is available, applying this official fix is the recommended remediation.

Description

Multiple vulnerabilities in aiohttp versions 3.4.2 up to but not including 3.10.0 allow an attacker to cause excessive or unbounded memory and CPU usage via specially crafted requests, leading to resource exhaustion.

References

Community reviews

Loading reviews…