Skip to main content
VulnerabilityPublished

CVE-2026-111750: AIOHTTP · Pure-Python parser request smuggling

Affects hermes-agentSource GCVE Database

0
Compare
Authoritative record:CVE-2026-111750· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium : upgrade to 2026.5.16_1 when convenient.

Data as of 30 Oct 2026, 09:15 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.06.3
Patch
Available – fixed in 2026.5.16_1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade hermes-agent to 2026.5.16_1.

Affected software

ProductAffectedFixed in
Homebrewhermes-agentpkg:brew/hermes-agentOther threatsAffected
  • >=0.21.6 <2026.5.16_1
  • >=2026.9.14
Fixed in
  • 2026.5.16_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade AIOHTTP to version 2026.5.16_1 or later where the vulnerability is fixed. As a workaround, switch to the default C parser instead of the pure Python parser (e.g., avoid using AIOHTTP_NO_EXTENSIONS).

Description

The pure Python HTTP parser in AIOHTTP is vulnerable to an HTTP request smuggling attack. This affects users who use the Python parser, such as those setting the AIOHTTP_NO_EXTENSIONS environment variable or not installing the standard wheel. The vulnerability can be mitigated by switching to the default C parser. A fix is available in version 2026.5.16_1.

References

Community reviews

Loading reviews…