CVE-2026-32710: An authenticated user can crash MariaDB versions 11.4 before 11.4.10 and 11.8 before 11.8.6 via a bug
Affects mariadbSource GCVE Database
Not known to be exploited · CVSS 8.6 High · fixed in 11.4.10 : patch mariadb soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.4.10
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10mariadbpkg:deb/ubuntu/mariadb?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSmariadbpkg:deb/ubuntu/mariadb?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade MariaDB to versions 11.4.10, 11.8.6, or 12.2.2 where this vulnerability is fixed. No other specific mitigations are indicated.
Description
An authenticated user can cause a crash in MariaDB versions 11.4 before 11.4.10 and 11.8 before 11.8.6 due to a bug in the JSON_SCHEMA_VALID() function. Under specific lab-controlled conditions, this crash could potentially be exploited for remote code execution. The vulnerability is fixed in MariaDB versions 11.4.10, 11.8.6, and 12.2.2.