Skip to main content
VulnerabilityPublished Updated

CVE-2026-32710: MariaDB server · Heap-based Buffer Overflow

Affects MariaDB serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High · fixed in 12.2.2 : patch MariaDB server soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 12.2.2, 11.8.6, 11.4.10
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade server to 12.2.2, 11.8.6 or 11.4.10; mariadb/server to 11.8.6 or 11.4.10.

Affected software

ProductAffectedFixed in
MariaDBserverAffected
  • >=12.1.2 <12.2.2
Fixed in
  • 12.2.2
MariaDBserverAffected
  • >=11.8.1 <11.8.6
Fixed in
  • 11.8.6
MariaDBserverAffected
  • >=11.4.1 <11.4.10
Fixed in
  • 11.4.10
GitHubmariadb/serverpkg:github/mariadb/serverOther threatsAffected
  • <11.4.10
  • <11.8.6
Fixed in
  • 11.4.10
  • 11.8.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade affected MariaDB server instances to versions 11.4.10, 11.8.6, or 12.2.2 or later, where the vulnerability is patched. In environments where immediate patching is not feasible, restrict access to the MariaDB server to trusted users and networks, enforce strong authentication and authorization controls, and monitor database logs for unusual JSON_SCHEMA_VALID() function usage patterns that could indicate exploitation attempts. Employ network segmentation to limit exposure of database servers and implement intrusion detection systems capable of recognizing anomalous database queries. Additionally, conduct regular audits of user privileges to minimize the number of accounts with the ability to invoke the vulnerable function. Consider deploying runtime application self-protection (RASP) or database activity monitoring solutions to detect and block suspicious behavior. Finally, maintain up-to-date backups and have an incident response plan ready to address potential exploitation scenarios.

Description

MariaDB server is a community developed fork of MySQL server. An authenticated user can crash MariaDB versions 11.4 before 11.4.10 and 11.8 before 11.8.6 via a bug in JSON_SCHEMA_VALID() function. Under certain conditions it might be possible to turn the crash into a remote code execution. These conditions require tight control over memory layout which is generally only attainable in a lab environment. This issue is fixed in MariaDB 11.4.10, MariaDB 11.8.6, and MariaDB 12.2.2.

References

Community reviews

Loading reviews…