Skip to main content
CVE-2026-88920VulnerabilityPublished Updated

Apache WSS4J · Authentication Bypass

Affects wss4jSource GCVE Database

0
Compare
Authoritative record:CVE-2026-88920· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 4.0.2 : patch wss4j as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10wss4jpkg:deb/ubuntu/wss4j?arch=source&distro=stonkingOther threatsAffected
  • =1.6.19-4build1
Fixed in–
Ubuntu 24.04 LTSwss4jpkg:deb/ubuntu/wss4j?arch=source&distro=nobleOther threatsAffected
  • =1.6.19-3
Fixed in–
Ubuntu 22.04 LTSwss4jpkg:deb/ubuntu/wss4j?arch=source&distro=jammyOther threatsAffected
  • =1.6.19-2
Fixed in–
Ubuntu 20.04 LTSwss4jpkg:deb/ubuntu/wss4j?arch=source&distro=focalOther threatsAffected
  • =1.6.19-2
Fixed in–
Ubuntu 18.04 LTSwss4jpkg:deb/ubuntu/wss4j?arch=source&distro=bionicOther threatsAffected
  • =1.6.19-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache WSS4J to version 4.0.2, 3.0.6, or 2.4.4 or later, where this vulnerability is fixed. No other mitigations or workarounds are indicated in the available data.

Description

An authentication bypass vulnerability exists in the DOM security processor of Apache WSS4J. This flaw allows unauthenticated remote attackers to forge authenticated SOAP messages by using a crafted unsigned SAML sender-vouches assertion with an attacker-controlled key. The issue is fixed in versions 4.0.2, 3.0.6, and 2.4.4 of Apache WSS4J.

References

Community reviews

Loading reviews…