Skip to main content
CVE-2026-74755VulnerabilityPublished Updated

Integer Underflow

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-74755· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 1.18.0 soon.

Data as of 30 Oct 2026, 21:06 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache bRPC and apache/brpc to 1.18.0.

Affected software

ProductAffectedFixed in
Apache bRPCapache/brpcAffected
  • <1.18.0
Fixed in
  • 1.18.0
GitHubapache/brpcpkg:github/apache/brpcOther threatsAffected
  • <1.18.0
Fixed in
  • 1.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache bRPC to version 1.18.0 or later, which includes the fix for this vulnerability. Alternatively, apply the patch available in PR https://github.com/apache/brpc/pull/3450. Default server configurations that do not enable the vulnerable protocols are not affected, so no action is required if those protocols are not in use.

Description

An integer underflow vulnerability exists in the mcpack2pb component of Apache bRPC versions prior to 1.18.0. This flaw allows remote attackers to crash a bRPC server by sending a specially crafted request with a string field having a zero value_size. The vulnerability arises because the UnparsedValue::as_string() function subtracts one from the value_size without validation, causing an underflow and an uncaught exception that aborts the process. Default server configurations are not affected as the vulnerable protocol is registered client-only by default.

References

Community reviews

Loading reviews…