Skip to main content
VulnerabilityPublished Updated

CVE-2024-45234: Fort · CWE-295

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-45234· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 1.6.3 : patch Fort soon.

Data as of 30 Oct 2026, 00:37 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Affects
Fort before 1.6.3
Patch
Available – fixed in 1.6.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

A fix is available in Fort version 1.6.3. Users should upgrade to version 1.6.3 or later to remediate this vulnerability. No other mitigation or workaround is indicated.

Description

CVE-2024-45234 is a vulnerability in Fort versions before 1.6.3 where a malicious RPKI repository can serve ROA or Manifest files with non-canonical signedAttrs encoding. This causes Fort's BER decoder to panic due to unexpected non-DER encoding, leading to Route Origin Validation unavailability and potentially compromised routing.

References

Community reviews

Loading reviews…