Skip to main content
VulnerabilityPublished Updated

CVE-2024-34507: includes/CommentFormatter/CommentParser.php · Basic XSS

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-34507· High 7.4

Not known to be exploited · CVSS 7.4 High · fixed in 1.41.1 : patch mediawiki soon.

Data as of 3 Nov 2026, 17:20 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.4
Patch
Available – fixed in 1.41.1, 1.40.3, 1.39.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade mediawiki/mediawiki to 1.41.1, 1.40.3 or 1.39.7.

Affected software

ProductAffectedFixed in
Packagistmediawiki/mediawikipkg:composer/mediawiki/mediawikiOther threatsAffected
  • <1.39.7
  • 1.40.0 <1.40.3
  • 1.41.0 <1.41.1
Fixed in
  • 1.39.7
  • 1.40.3
  • 1.41.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in MediaWiki versions 1.39.7, 1.40.3, and 1.41.1. Users should upgrade to these or later versions to remediate the vulnerability. Since this is a software vulnerability and not a cloud service, manual patching is required. No vendor advisory content was provided to indicate alternative mitigations or that no action is required.

Description

A cross-site scripting (XSS) vulnerability exists in MediaWiki versions before 1.39.7, 1.40.x before 1.40.3, and 1.41.x before 1.41.1 due to improper handling of the 0x1b character in the CommentParser.php component. This flaw can be triggered via the Special:RecentChanges page, potentially allowing an attacker to execute script code in the context of the affected site.

References

Community reviews

Loading reviews…