CVE-2026-43504: Prosody · Incorrect Authorization
Source GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 13.0.5 : update Prosody when convenient.
Data as of 27 Oct 2026, 00:42 UTC
- Affects
- Prosody before 0.12.6
- Patch
- Available – fixed in 13.0.5, 0.12.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 1 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
Since the vulnerability affects specific versions before 0.12.6 and before 13.0.5, upgrading Prosody to version 0.12.6 or 13.0.5 or later is recommended if available. If upgrading is not immediately possible, disabling the mod_proxy65 module or avoiding its use in paused scenarios may mitigate the risk. Users should consult the official Prosody advisories or vendor guidance for confirmed fixes and mitigation steps.
Description
A vulnerability in Prosody versions before 0.12.6 and 1.0.0 through 13.0.0 before 13.0.5 affects the mod_proxy65 module. The issue arises because mod_proxy65 mishandles access control when in a paused state, allowing unauthenticated traffic to be relayed. This can lead to integrity and availability impacts. The vulnerability has a CVSS score of 6.5, indicating a medium severity level.