CVE-2026-43504: Prosody · Incorrect Authorization
Affects ProsodySource GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 13.0.5 or 0.12.6 when convenient.
Data as of 27 Oct 2026, 00:43 UTC
- Patch
- Available – fixed in 13.0.5, 0.12.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 1 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Prosody to 13.0.5 or 0.12.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Prosody Prosody | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, consider disabling mod_proxy65 if not required or implementing additional access controls externally to mitigate unauthorized relaying.
Description
CVE-2026-43504 is an authorization vulnerability in Prosody affecting versions before 0.12.6 and 1.0.0 through 13.0.0 before 13.0.5 when the mod_proxy65 module is enabled. The flaw allows relaying of unauthenticated traffic due to improper access control handling in a paused state of the module.