CVE-2026-42312: pyload · Improper Certificate Validation
Affects pyloadSource GCVE Database
Not known to be exploited · CVSS 6.8 Medium : upgrade to 0.5.0b3.dev100 when convenient.
Data as of 27 Oct 2026, 00:12 UTC
- Patch
- Available – fixed in 0.5.0b3.dev100
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pyload to 0.5.0b3.dev100.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIpyloadpkg:pypi/pyloadOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade pyLoad to version 0.5.0b3.dev100 or later, where this vulnerability is fixed by including 'general.ssl_verify' in the admin-only allowlist. Until upgrading, restrict SETTINGS permission to trusted users only to prevent unauthorized disabling of SSL verification. No other vendor advisories indicate alternative mitigations or that the issue is already mitigated.
Description
CVE-2026-42312 is a vulnerability in pyLoad, a Python-based download manager, affecting versions prior to 0.5.0b3.dev100. The flaw allows any authenticated user with non-admin SETTINGS permission to disable SSL certificate verification by setting the 'general.ssl_verify' option to off. This disables TLS peer and hostname verification for outbound requests, enabling an on-path attacker to present forged certificates and potentially intercept or manipulate data. The issue arises because 'general.ssl_verify' is not included in the admin-only allowlist that restricts security-sensitive options. This vulnerability is part of a series of similar issues related to the allowlist and is fixed in version 0.5.0b3.dev100.