Skip to main content
VulnerabilityPublished Updated

CVE-2024-46951: psi/zcolor.c · CWE-824

Affects ghostpdlSource GCVE Database

0
Compare
Authoritative record:CVE-2024-46951· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 10.04.0 soon.

Data as of 29 Oct 2026, 23:00 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.8
Affects
Artifex Ghostscript before 10.04.0
Patch
Available – fixed in 10.04.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade artifexsoftware/ghostpdl to 10.04.0.

Affected software

ProductAffectedFixed in
GitHubartifexsoftware/ghostpdlpkg:github/artifexsoftware/ghostpdlOther threatsAffected
  • <10.04.0
Fixed in
  • 10.04.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Artifex Ghostscript version 10.04.0 and later. Users should upgrade to version 10.04.0 or apply the patch provided by their vendor, such as the SUSE update SUSE-SU-2024:3942-1. No additional mitigation steps are indicated by the vendor advisory.

Description

A vulnerability in Artifex Ghostscript before version 10.04.0 exists in the psi/zcolor.c component. The flaw involves an unchecked implementation pointer in the Pattern color space, which could allow an attacker to execute arbitrary code. The vulnerability has a high severity rating with a CVSS score of 7.8.

References

Community reviews

Loading reviews…