Skip to main content
VulnerabilityPublished Updated

CVE-2024-34402: uriparser · Integer Overflow

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-34402· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 0.9.8 soon.

Data as of 3 Nov 2026, 17:20 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade uriparser/uriparser to 0.9.8.

Affected software

ProductAffectedFixed in
GitHuburiparser/uriparserpkg:github/uriparser/uriparserOther threatsAffected
  • <0.9.8
Fixed in
  • 0.9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider avoiding use of vulnerable versions or applying any available workarounds from the vendor.

Description

A vulnerability in uriparser versions through 0.9.7 allows an integer overflow in the ComposeQueryEngine function within UriQuery.c. This overflow occurs when processing long keys or values, leading to a buffer overflow condition.

References

Community reviews

Loading reviews…