CVE-2026-63418: monitoring-plugins · Integer Overflow or Wraparound
Affects monitoring-pluginsSource CVE Database V5
Not known to be exploited · CVSS 7.0 High : upgrade to 3.0.1 soon.
Data as of 3 Nov 2026, 18:28 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.0 |
|---|
- Patch
- Available – fixed in 3.0.1
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade monitoring-plugins and monitoring-plugins/monitoring-plugins to 3.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| monitoring-pluginsmonitoring-plugins | Affected
| Fixed in
|
GitHubmonitoring-plugins/monitoring-pluginspkg:github/monitoring-plugins/monitoring-pluginsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade monitoring-plugins to version 3.0.1 or later, where this integer overflow and out-of-bounds write issue is fixed. Systems using cap_net_raw file capabilities instead of setuid are not vulnerable to privilege escalation via this flaw. No other mitigations are indicated by the vendor advisory.
Description
CVE-2026-63418 is an integer overflow vulnerability in monitoring-plugins' check_icmp component versions from 3.0.0-rc1 up to but not including 3.0.1. The flaw occurs because the number of hosts is stored in an unsigned short, causing a wraparound when more than 65,535 hosts are specified. This leads to an undersized allocation and out-of-bounds writes before privilege dropping. On systems where check_icmp is setuid root, this can allow a local low-privileged attacker to corrupt heap memory with elevated privileges. The issue is fixed in version 3.0.1.
References
- github.com/monitoring-plugins/monitoring-plugins/security/advisories/GHSA-xvvw-4j77-rp7q (opens in a new tab)
- github.com/monitoring-plugins/monitoring-plugins/commit/c35c12e58d326ffbd6cfb3c9097653f9f3fb2f4a (opens in a new tab)
- github.com/monitoring-plugins/monitoring-plugins/releases/tag/v3.0.1 (opens in a new tab)