Out-of-bounds Read
Source GCVE Database
Not known to be exploited · CVSS 8.1 High · fixed in 6.0.2 : patch Amazon Aurora PostgreSQL with Babelfish soon.
Data as of 6 Nov 2026, 22:47 UTC
Thin evidence
One scorer or none| CNA (AMZN) | CVSS 3.1 | 8.1 |
|---|---|---|
| CNA (AMZN) | CVSS 4.0 | 7.2 |
- Patch
- Available – fixed in 6.0.2, 5.4.2, 5.3.2 +21
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AWSbabelfish-for-postgresql | Affected
| Fixed in– |
| AmazonAmazon Aurora PostgreSQL with Babelfish | Affected
| Fixed in
|
GitHubbabelfish-for-postgresql/babelfish-for-postgresqlpkg:github/babelfish-for-postgresql/babelfish-for-postgresqlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available. Users should upgrade Babelfish for PostgreSQL extension to versions 4.10, 5.6, 6.1 or later. Customers using Amazon Aurora PostgreSQL with Babelfish should upgrade their clusters to one of the specified patched versions (e.g., 13.9.16 (1.5.5), 14.22.3 (2.16.1), 17.10.1 (5.6.0), 18.4.1 (6.1.0), or later) and apply any pending maintenance updates. As a temporary workaround, restrict network access to the TDS port (default 1433) to limit exposure.
Description
An out-of-bounds read vulnerability exists in the TDS RPC procedure-name parser of the Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4, and in Amazon Aurora PostgreSQL with Babelfish. This flaw may allow remote authenticated users to read adjacent process memory or cause a denial of service via a malformed TDS RPC request to the default TDS port 1433. Upgrades to fixed versions or restricting network access to the TDS port are recommended mitigations.
References
- nvd.nist.gov/vuln/detail/CVE-2026-119924 (opens in a new tab)
- aws.amazon.com/security/security-bulletins/2026-166-aws (opens in a new tab)
- github.com/babelfish-for-postgresql/babelfish-for-postgresql/releases/tag/BABEL_4_10_0__PG_16_14 (opens in a new tab)
- github.com/babelfish-for-postgresql/babelfish-for-postgresql/releases/tag/BABEL_5_6_0__PG_17_10 (opens in a new tab)
- github.com/babelfish-for-postgresql/babelfish-for-postgresql/releases/tag/BABEL_6_1_0__PG_18_4 (opens in a new tab)