Skip to main content
VulnerabilityPublished

CVE-2026-118237: GitHub Enterprise Server · Out-of-bounds Read Vulnerability Was Identified

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-118237· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 3.22.3 : update Enterprise Server when convenient.

Data as of 4 Nov 2026, 02:13 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_P)CVSS 4.05.3
Patch
Available – fixed in 3.22.3, 3.21.8, 3.20.10 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade Enterprise Server to 3.22.3, 3.21.8, 3.20.10 or 3.19.14.

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.22.0 <3.22.3
Fixed in
  • 3.22.3
GitHubEnterprise ServerAffected
  • >=3.21.0 <3.21.8
Fixed in
  • 3.21.8
GitHubEnterprise ServerAffected
  • >=3.20.0 <3.20.10
Fixed in
  • 3.20.10
GitHubEnterprise ServerAffected
  • >=3.19.0 <3.19.14
Fixed in
  • 3.19.14

AI-suggested

This vulnerability has been fixed in GitHub Enterprise Server versions 3.22.3, 3.21.8, 3.20.10, and 3.19.14. Users should upgrade to one of these fixed versions or later to remediate the issue. No additional mitigation steps are required beyond applying the official patches.

Description

An out-of-bounds read vulnerability (CWE-125) exists in GitHub Enterprise Server's Git service (babeld) SSH implementation. The flaw occurs when the session identifier is sized by the current digest length rather than its own, allowing an attacker with SSH access to re-key to a longer hash algorithm and cause adjacent process memory to be signed and returned to the client. This could lead to limited memory disclosure. The issue affects all versions prior to 3.23 and was fixed in versions 3.22.3, 3.21.8, 3.20.10, and 3.19.14. No known exploits in the wild have been reported.

References

Community reviews

Loading reviews…