Skip to main content
VulnerabilityPublished

CVE-2026-118237: GitHub Enterprise Server · Out-of-bounds Read

Affects GitHub Enterprise ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium · fixed in 3.22.3 : update GitHub Enterprise Server when convenient.

Data as of 3 Nov 2026, 23:13 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_P)CVSS 4.05.3
Patch
Available – fixed in 3.22.3, 3.21.8, 3.20.10 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade GitHub Enterprise Server to 3.22.3, 3.21.8, 3.20.10 or 3.19.14.

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.22.0 <3.22.3
Fixed in
  • 3.22.3
GitHubEnterprise ServerAffected
  • >=3.21.0 <3.21.8
Fixed in
  • 3.21.8
GitHubEnterprise ServerAffected
  • >=3.20.0 <3.20.10
Fixed in
  • 3.20.10
GitHubEnterprise ServerAffected
  • >=3.19.0 <3.19.14
Fixed in
  • 3.19.14

AI-suggested

This vulnerability has been fixed in GitHub Enterprise Server versions 3.19.14, 3.20.10, 3.21.8, and 3.22.3. Users should upgrade to one of these fixed versions or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-118237 is an out-of-bounds read vulnerability in GitHub Enterprise Server's Git service (babeld) SSH implementation. It occurs when the session identifier is sized incorrectly during host key possession proof, allowing an attacker with SSH access to cause adjacent process memory to be signed and returned. This could lead to limited memory disclosure. The issue affects versions prior to 3.19.14, 3.20.10, 3.21.8, and 3.22.3 and has been fixed in these releases.

References

Community reviews

Loading reviews…