Skip to main content
VulnerabilityPublished

CVE-2026-110288: GitHub Enterprise Server · Cross-Site Request Forgery

Affects GitHub Enterprise ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium · fixed in 3.22.3 : update GitHub Enterprise Server when convenient.

Data as of 3 Nov 2026, 23:13 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_P)CVSS 4.05.3
Patch
Available – fixed in 3.22.3, 3.21.8, 3.20.10 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade GitHub Enterprise Server to 3.22.3, 3.21.8, 3.20.10 or 3.19.14.

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.22.0 <3.22.3
Fixed in
  • 3.22.3
GitHubEnterprise ServerAffected
  • >=3.21.0 <3.21.8
Fixed in
  • 3.21.8
GitHubEnterprise ServerAffected
  • >=3.20.0 <3.20.10
Fixed in
  • 3.20.10
GitHubEnterprise ServerAffected
  • >=3.19.0 <3.19.14
Fixed in
  • 3.19.14

AI-suggested

Fixed versions 3.19.14, 3.20.10, 3.21.8, and 3.22.3 are available and should be applied to remediate this vulnerability. Users should upgrade affected GitHub Enterprise Server instances to one of these versions. No additional mitigation is required if these versions are deployed.

Description

CVE-2026-110288 is a cross-site request forgery (CSRF) vulnerability in GitHub Enterprise Server that allows an unauthenticated attacker to delete stored Slack and Microsoft Teams ChatOps configuration and provider credentials. Exploitation requires that ChatOps integrations are configured and that an authenticated Management Console operator visits attacker-controlled content. This vulnerability affects versions prior to 3.19.14, 3.20.10, 3.21.8, and 3.22.3 and was fixed in those versions. The impact includes disruption of ChatOps notifications and commands when configurations are applied or services reloaded.

References

Community reviews

Loading reviews…