Skip to main content
VulnerabilityPublished Updated

CVE-2024-21490: Angular.js · This affects versions of the package angular from 1.3.0; versions of the package

Affects angular.jsSource GCVE Database

0
Authoritative record:CVE-2024-21490· High 7.5

Public exploit available · CVSS 7.5 High · fixed in 1.5.10-1ubuntu0.1~esm1 : patch angular.js as a priority.

Data as of 28 Oct 2026, 22:28 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.5.10-1ubuntu0.1~esm1, 1.7.9-1ubuntu0.1~esm1, 1.8.2-2ubuntu0.1 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSangular.jspkg:deb/ubuntu/angular.js?arch=source&distro=nobleOther threatsAffected
  • <1.8.3-1ubuntu0.24.04.1
Fixed in
  • 1.8.3-1ubuntu0.24.04.1
Ubuntu 22.04 LTSangular.jspkg:deb/ubuntu/angular.js?arch=source&distro=jammyOther threatsAffected
  • <1.8.2-2ubuntu0.1
Fixed in
  • 1.8.2-2ubuntu0.1
Ubuntu Pro 20.04 LTSangular.jspkg:deb/ubuntu/angular.js?arch=source&distro=esm-apps/focalOther threatsAffected
  • <1.7.9-1ubuntu0.1~esm1
Fixed in
  • 1.7.9-1ubuntu0.1~esm1
Ubuntu Pro 18.04 LTSangular.jspkg:deb/ubuntu/angular.js?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <1.5.10-1ubuntu0.1~esm1
Fixed in
  • 1.5.10-1ubuntu0.1~esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

This affects versions of the package angular from 1.3.0; versions of the package angularjs from 1.3.0. A regular expression used to split the value of the ng-srcset directive is vulnerable to super-linear runtime due to backtracking. With large carefully-crafted input, this can result in catastrophic backtracking and cause a denial of service. **Note:** This package is EOL and will not receive any updates to address this issue. Users should migrate to [@angular/core](https://www.npmjs.com/package/@angular/core).

References

Community reviews

Loading reviews…