Skip to main content
VulnerabilityPublished Updated

CVE-2024-26020: Ankitects Anki arbitrary script execution vulnerability

Affects ankiSource GCVE Database

0
Compare
Authoritative record:CVE-2024-26020· Critical 9.6

Not known to be exploited · CVSS 9.6 Critical : upgrade to 24.06 as a priority.

Data as of 4 Nov 2026, 17:27 UTC

CVSS 3.1 base score
9.6Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (talos)CVSS 3.19.6
Patch
Available – fixed in 24.06
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade anki to 24.06.

Affected software

ProductAffectedFixed in
PyPIankiAffected
  • <24.06
Fixed in
  • 24.06

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should update Ankitects Anki to version 24.06 or later, where this vulnerability is fixed. Applying this official patch fully mitigates the risk. No other specific mitigations are indicated.

Description

Ankitects Anki versions prior to 24.06 contain an arbitrary script execution vulnerability in the MPV functionality. A specially crafted flashcard can trigger arbitrary code execution, allowing an attacker to execute malicious scripts. This vulnerability is critical and has been fixed in version 24.06.

References

Community reviews

Loading reviews…