CVE-2025-67895: Apache Airflow Providers Edge3 exposes internal API allowing RCE in web server context
Affects apache-airflow-providers-edge3Source GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.0.0 as a priority.
Data as of 26 Oct 2026, 22:27 UTC
- Patch
- Available – fixed in 2.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade apache-airflow-providers-edge3 to 2.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIapache-airflow-providers-edge3 | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Edge3 Worker RPC RCE on Airflow 2. This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if projects installed and configured it on Airflow 2. The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if projects installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do. If projects installed and configured Edge3 provider for Airflow 2, they should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (>=2.0.0) has a minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2. If projects used Edge Provider in Airflow 3, you they are not affected.
References
- nvd.nist.gov/vuln/detail/CVE-2025-67895 (opens in a new tab)
- github.com/apache/airflow/pull/59143 (opens in a new tab)
- github.com/apache/airflow (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-edge3/PYSEC-2026-276.yaml (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2025-87.yaml (opens in a new tab)
- lists.apache.org/thread/hhnmmzkj5qx5gbk6pdkh8tcsx5oj1nqs (opens in a new tab)
- pypi.org/project/apache-airflow-providers-edge3 (opens in a new tab)
- openwall.com/lists/oss-security/2025/12/16/3 (opens in a new tab)