Skip to main content
CVE-2025-67895VulnerabilityPublished

CVE-2025-67895: Apache Airflow Providers Edge3 · Incorrect Resource Transfer Between Spheres

Affects Apache Airflow Providers Edge3Source CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.0.0 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 67% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade apache-airflow-providers-edge3 to 2.0.0.

Affected software

ProductAffectedFixed in
PyPIapache-airflow-providers-edge3pkg:pypi/apache-airflow-providers-edge3Other threatsAffected
  • <2.0.0
Fixed in
  • 2.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-67895, European organizations should take immediate and specific actions beyond generic patching advice: 1) Identify all instances of Apache Airflow 2 deployments with the Edge3 provider installed. 2) Uninstall the Edge3 provider from Airflow 2 environments as it contains the vulnerable non-public API. 3) Plan and execute a migration to Apache Airflow 3, ensuring that the Edge3 provider version is upgraded to 2.0.0 or later, which removes the vulnerable code. 4) Restrict DAG author privileges to trusted personnel only, minimizing the risk of insider exploitation. 5) Implement network segmentation and access controls to limit exposure of the Airflow webserver to untrusted networks. 6) Monitor Airflow logs and system behavior for unusual activity indicative of exploitation attempts. 7) Conduct security audits and code reviews of DAGs to detect potentially malicious or unauthorized code. 8) Stay updated with Apache Airflow security advisories and apply future patches promptly. These targeted steps will reduce the attack surface and prevent exploitation of this critical vulnerability.

Description

Edge3 Worker RPC RCE on Airflow 2. This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if you installed and configured it on Airflow 2. The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if you installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do. If you installed and configured Edge3 provider for Airflow 2, you should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (>=2.0.0) has minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2. If you used Edge Provider in Airflow 3, you are not affected.

References

Community reviews

Loading reviews…