Skip to main content
VulnerabilityPublished

CVE-2026-86471: Apache CouchDB · Admin credentials leading to code execution as operating system user

Affects couchdbSource GCVE Database

0
Compare
Authoritative record:CVE-2026-86471· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.5.3 as a priority.

Data as of 29 Oct 2026, 13:19 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.5.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L/E:A/S:N/AU:Y/R:U/V:C/RE:M/U:Red

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade couchdb to 3.5.3.

Affected software

ProductAffectedFixed in
Bitnamicouchdbpkg:bitnami/couchdbOther threatsAffected
  • <3.5.3
Fixed in
  • 3.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache CouchDB to version 3.5.3 or later, which contains the official fix for this vulnerability.

Description

Apache CouchDB versions 3.5.2 and earlier contain a vulnerability where an unvalidated runtime configuration value allows a CouchDB server administrator to execute arbitrary shell commands as the operating system user running CouchDB. This issue is fixed in version 3.5.3.

References

Community reviews

Loading reviews…