Skip to main content
VulnerabilityPublished

CVE-2026-90797: Apache CouchDB · Pre-authentication gzip decompression bomb via POST /_session

Affects couchdbSource GCVE Database

0
Compare
Authoritative record:CVE-2026-90797· High 7.7

Not known to be exploited · CVSS 7.7 High : upgrade to 3.5.3 soon.

Data as of 29 Oct 2026, 13:19 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.5.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/E:U/S:N/AU:Y/R:A/V:D/RE:M/U:Red

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade couchdb to 3.5.3.

Affected software

ProductAffectedFixed in
Bitnamicouchdbpkg:bitnami/couchdbOther threatsAffected
  • <3.5.3
Fixed in
  • 3.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache CouchDB to version 3.5.3 or later, where this vulnerability is fixed. No other mitigation is indicated or required.

Description

Apache CouchDB versions 3.5.2 and earlier contain a vulnerability in the chttpd component where an unlimited gzip decompression routine can be triggered by any remote client via a POST request to /_session. This flaw allows denial of service through memory exhaustion. The issue is fixed in version 3.5.3.

References

Community reviews

Loading reviews…