Skip to main content
VulnerabilityPublished

CVE-2026-114442: Apache HertzBeat versions 1.7.1, 1.7.2, 1.7.3, 1.8.0, and 1.9.0 have incomplete XPath expression

Affects hertzbeatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-114442· Medium

Not known to be exploited · fixed in 1.9.1 : update hertzbeat when convenient.

Data as of 3 Nov 2026, 13:28 UTC

Severity
Medium

Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 1.9.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
GitHubapache/hertzbeatpkg:github/apache/hertzbeatOther threatsAffected
  • >=1.7.1 <=1.9.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache HertzBeat to version 1.9.1 or later, where the vulnerability is fixed. No other mitigation or temporary workaround is indicated.

Description

Apache HertzBeat versions 1.7.1 through 1.9.0 contain incomplete XPath expression validation in the HTTP collector XML parsing path. Authenticated users with permission to create monitor templates can supply XPath expressions that are evaluated without proper validation, potentially causing excessive CPU consumption and impairing collector availability. This issue is a follow-up to a previous incomplete fix (CVE-2026-24343). The vulnerability is fixed in version 1.9.1.

References

Community reviews

Loading reviews…