Skip to main content
CVE-2026-115644VulnerabilityPublished

Apache Kafka Connect contains an authentication bypass vulnerability affecting the admin REST API when admin.listeners

Source GCVE Database

0
Authoritative record:CVE-2026-115644· High

Not known to be exploited : upgrade to 4.3.2 or 4.2.2 soon.

Data as of 28 Oct 2026, 22:12 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 4.3.2, 4.2.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 4.3.2 or 4.2.2.

Affected software

ProductAffectedFixed in
Apache Kafkaorg.apache.kafka:connect-runtimeAffected
  • >=4.3.0 <4.3.2
Fixed in
  • 4.3.2
Apache Kafkaorg.apache.kafka:connect-runtimeAffected
  • >=2.4.0 <4.2.2
Fixed in
  • 4.2.2
MavenApache Software Foundation/org.apache.kafka:connect-runtimepkg:maven/Apache Software Foundation/org.apache.kafka:connect-runtimeOther threatsAffected
  • >=2.4.0 <4.2.2
  • >=4.3.0 <4.3.2
Fixed in
  • 4.2.2
  • 4.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Kafka Connect to version 4.2.2, 4.3.2, or 4.4.0 or later, where the vulnerability is fixed. If immediate upgrade is not possible, remove or leave the admin.listeners configuration unset so that admin resources share the main listener and inherit its security extensions, preventing unauthenticated access.

Description

Apache Kafka Connect has an authentication bypass vulnerability in the admin REST API when the admin.listeners property is configured separately from the main listeners. This misconfiguration causes security extensions not to apply to the admin listener endpoints, allowing unauthenticated access. An attacker with network access to the admin listener can read logger configurations and modify logger levels cluster-wide, potentially impacting availability and observability. The issue is fixed in Apache Kafka versions 4.2.2, 4.3.2, and 4.4.0. Users unable to upgrade immediately can mitigate by removing or leaving admin.listeners unset, causing admin resources to share the main listener and inherit its security extensions.

References

Community reviews

Loading reviews…