Skip to main content
VulnerabilityPublished

CVE-2026-115644: Apache Kafka · Connect Admin REST API Authentication Bypass via Unapplied REST Extensions

Affects Apache KafkaSource CVE Database V5

0

Not known to be exploited : upgrade to 4.3.2 or 4.2.2 soon.

Data as of 28 Oct 2026, 20:13 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 4.3.2, 4.2.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 4.3.2 or 4.2.2.

Affected software

ProductAffectedFixed in
Apache Kafkaorg.apache.kafka:connect-runtimeAffected
  • >=4.3.0 <4.3.2
Fixed in
  • 4.3.2
Apache Kafkaorg.apache.kafka:connect-runtimeAffected
  • >=2.4.0 <4.2.2
Fixed in
  • 4.2.2
MavenApache Software Foundation/org.apache.kafka:connect-runtimepkg:maven/Apache Software Foundation/org.apache.kafka:connect-runtimeOther threatsAffected
  • >=2.4.0 <4.2.2
  • >=4.3.0 <4.3.2
Fixed in
  • 4.2.2
  • 4.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users unable to upgrade immediately should remove or leave unset the admin.listeners configuration, causing admin resources to share the regular listener and inherit its security extensions. Upgrading to Apache Kafka versions 4.2.2, 4.3.2, or later fully resolves the vulnerability by applying REST extensions to admin.listeners.

Description

Apache Kafka Connect contains an authentication bypass vulnerability affecting the admin REST API when admin.listeners is configured with a separate listener from the main listeners property. When operators isolate the admin REST API by explicitly configuring the "admin.listeners" property, REST extensions specified via rest.extension.classes (such as BasicAuthSecurityRestExtension) are not registered or applied to the admin resource configuration. While the primary REST API listener (configured via listeners) enforces configured authentication and authorization filters, endpoints mounted under the separate admin listener (/admin/loggers) fail to inherit or instantiate these extension filters. As a result, the admin logger endpoint accepts unauthenticated read and write requests even when security extensions are active on the main listener. Impact: An unauthenticated attacker with network access to the admin listener can: 1. Read the complete set of logger names and levels, disclosing loaded class names and which security extensions are in use. 2. Write logger levels, including with scope=cluster which propagates the change to all workers in the Connect cluster. This can be used to suppress logging (setting root to OFF) or generate excessive log output (setting root to TRACE), potentially impacting availability and observability. Mitigation: Users who cannot upgrade immediately can remove the admin.listeners configuration (or leave it unset). When unset, admin resources share the regular listener and inherit its security extensions. Resolution: From Apache Kafka 4.2.2, 4.3.2, and 4.4.0, we make sure the REST extensions specified via "rest.extension.classes" will also apply to "admin.listeners".

References

Community reviews

Loading reviews…