Skip to main content
VulnerabilityPublished

CVE-2026-83525: Apache Kafka · Use of Incorrect Operator

Affects Apache KafkaSource CVE Database V5

0

Not known to be exploited : upgrade to 4.3.2 or 4.2.2 soon.

Data as of 28 Oct 2026, 20:13 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 4.3.2, 4.2.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 4.3.2 or 4.2.2.

Affected software

ProductAffectedFixed in
Apache Kafkaorg.apache.kafka:kafka-raftAffected
  • >=4.3.0 <4.3.2
Fixed in
  • 4.3.2
Apache Kafkaorg.apache.kafka:kafka-raftAffected
  • >=2.8.0 <4.2.2
Fixed in
  • 4.2.2
MavenApache Software Foundation/org.apache.kafka:kafka-raftpkg:maven/Apache Software Foundation/org.apache.kafka:kafka-raftOther threatsAffected
  • >=2.8.0 <4.2.2
  • >=4.3.0 <4.3.2
Fixed in
  • 4.2.2
  • 4.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Kafka to version 4.2.2, 4.3.2, or 4.4.0 to remediate this vulnerability. Users on unsupported branches (4.1.x and earlier) are advised to upgrade to 4.2.2 or later. No other mitigation or workaround is indicated in the vendor advisory.

Description

Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions. Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.

References

Community reviews

Loading reviews…