Skip to main content
VulnerabilityPublished

CVE-2026-116593: Apache Kafka · Kafka Connect configuration provider values exposed via validation REST API endpoint

Affects Apache KafkaSource CVE Database V5

0

Not known to be exploited : upgrade to 4.3.2 or 4.2.2 soon.

Data as of 28 Oct 2026, 20:13 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 4.3.2, 4.2.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 4.3.2 or 4.2.2.

Affected software

ProductAffectedFixed in
Apache Kafkaorg.apache.kafka:connect-runtimeAffected
  • >=4.3.0 <4.3.2
Fixed in
  • 4.3.2
Apache Kafkaorg.apache.kafka:connect-runtimeAffected
  • >=2.4.0 <4.2.2
Fixed in
  • 4.2.2
MavenApache Software Foundation/org.apache.kafka:connect-runtimepkg:maven/Apache Software Foundation/org.apache.kafka:connect-runtimeOther threatsAffected
  • >=2.4.0 <4.2.2
  • >=4.3.0 <4.3.2
Fixed in
  • 4.2.2
  • 4.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Kafka Connect to version 4.2.2, 4.3.2, 4.4.0 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.

Description

Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations. Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime. An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker. Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.

References

Community reviews

Loading reviews…