Skip to main content
VulnerabilityPublished

CVE-2026-111073: Apache Kafka · Data Amplification

Affects Apache KafkaSource CVE Database V5

0

Not known to be exploited · fixed in 4.2.2 : patch Apache Kafka soon.

Data as of 28 Oct 2026, 17:22 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 4.2.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Kafkaorg.apache.kafka:kafkaAffected
  • >=3.7.0 <=4.1.2
  • >=4.2.0 <=4.2.1
  • =4.3.0
Fixed in–
MavenApache Software Foundation/org.apache.kafka:kafkapkg:maven/Apache Software Foundation/org.apache.kafka:kafkaOther threatsAffected
  • >=3.7.0 <=4.1.2
  • >=4.2.0 <=4.2.1
  • =4.3.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Kafka to version 4.2.2, 4.3.1, or 4.4.0 where the decompression size is properly bounded. On affected versions, no configuration fully prevents the amplification; lowering telemetry.max.bytes reduces the worst-case decompressed size proportionally but is only a partial mitigation.

Description

CVE-2026-111073 is a vulnerability in Apache Kafka's PushTelemetry API where the broker validates only the compressed size of telemetry data before decompression. This allows an authenticated client to send a small compressed payload that decompresses to a very large size, causing excessive heap memory consumption. This can lead to OutOfMemoryError, degrading or crashing the broker and potentially affecting cluster availability. The vulnerability affects Apache Kafka versions from 3.7.0 through 4.1.2, 4.2.0 through 4.2.1, and version 4.3.0. Fixed versions include 4.2.2, 4.3.1, and 4.4.0, which enforce a maximum decompressed size limit equal to telemetry.max.bytes (default 1 MB).

References

Community reviews

Loading reviews…