CVE-2026-111551: Apache Kafka · Excessive Memory Allocation
Affects Apache KafkaSource CVE Database V5
Not known to be exploited · fixed in 4.2.2 : patch Apache Kafka soon.
Data as of 28 Oct 2026, 17:23 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
- Patch
- Available – fixed in 4.2.2
Exploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Kafkaorg.apache.kafka:kafka-streams | Affected
| Fixed in– |
| Apache Kafkaorg.apache.kafka:kafka-clients | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.kafka:kafka-streamspkg:maven/Apache Software Foundation/org.apache.kafka:kafka-streamsOther threats | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.kafka:kafka-clientspkg:maven/Apache Software Foundation/org.apache.kafka:kafka-clientsOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache Kafka to versions 4.2.2, 4.3.2, or 4.4.0 where the vulnerability is fixed by validating size fields before allocation. Additionally, if authorization is enabled, restrict write access to internal topics and consumer groups to their respective principals and limit who can produce to topics consumed with ListSerde. These measures reduce the attack surface and prevent unauthorized injection of crafted records.
Description
CVE-2026-111551 is a vulnerability in Apache Kafka where several deserialization paths allocate memory based on unvalidated size or count fields from input data. This can lead to excessive memory allocation, causing OutOfMemoryError and crashing the affected consumer or Kafka Streams thread. The issue affects Kafka versions up to 4.1.2, 4.2.1, and 4.3.1. The vulnerability is mitigated by upgrading to Apache Kafka 4.2.2, 4.3.2, or 4.4.0, which include validation of declared sizes before allocation.