Skip to main content
VulnerabilityPublished

CVE-2026-110985: Apache Kafka · Insufficient Verification of Data Authenticity

Affects Apache KafkaSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · fixed in 4.2.2 : patch Apache Kafka soon.

Data as of 28 Oct 2026, 17:22 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 4.2.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Kafkaorg.apache.kafka:kafkaAffected
  • >=4.1.0 <=4.1.2
  • >=4.2.0 <=4.2.1
  • =4.3.0
Fixed in–
MavenApache Software Foundation/org.apache.kafka:kafkapkg:maven/Apache Software Foundation/org.apache.kafka:kafkaOther threatsAffected
  • >=4.1.0 <=4.1.2
  • >=4.2.0 <=4.2.1
  • =4.3.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability on all affected versions without upgrading, administrators must configure the sasl.oauthbearer.jwks.endpoint.url parameter for every listener and mechanism using OAuthBearerValidatorCallbackHandler, or alternatively configure a signature-verifying sasl.oauthbearer.jwt.validator.class. Upgrading to Apache Kafka versions 4.2.2, 4.3.1, or 4.4.0 is recommended, as these versions prevent brokers from starting if signature verification is not properly configured, enforcing secure defaults.

Description

CVE-2026-110985 is a vulnerability in Apache Kafka brokers using SASL/OAUTHBEARER authentication with the default JWT validator. If the configuration parameter sasl.oauthbearer.jwks.endpoint.url is not set and no custom verification key resolver is provided, the broker falls back to a validator that does not verify JWT signatures, algorithms, or issuers. This allows an unauthenticated remote attacker to forge any JWT token, including those asserting superuser privileges, gaining full cluster access. The issue affects specific Kafka versions prior to fixed releases. The vulnerability is resolved in Apache Kafka versions 4.2.2, 4.3.1, and 4.4.0, where the broker fails to start if signature verification is not properly configured.

References

Community reviews

Loading reviews…